
1- Open	EEGLAB	
Tip:	to	figure	out	how	to	make	scripts	in	eeglab.	First	run	a	command	and	then	
type	eegh	in	command	line.	This	will	give	you	the	command	structure	of	what	
you	have	just	run	and	how	the	commands	are	meant	to	be	structured	
Preprocessing	steps:	2-8	(9)	
Epoching	and	ICA:	10-12		
Averaging	and	Stats:	13-16		
	

2- Import	data		
a. File>Import	data	>From	Netstation	binary	simple	file	

i. Load	corresponding	Netstation	file	

	

Note:	to	load	an	existing	data	set:		

b. The	information	that	pops	up	in	EEGlab	tells	you	about	the	size	of	the	
file,	number	of	events,	number	of	channels	etc.	



	
c. Save	data	so	it	is	easier	to	have	the	data	stored	as	a	.set	file	in	eeglab	–	

to	reopen	
d. SAVE	(“ss_expt_name_scroll”)	

	
3- Plot	and	remove	artefacts	(optional)	

a. It	is	sometimes	a	good	idea	to	scroll	through	the	entire	raw	data	–	to	
make	sure	everything	went	ok	during	recording.	While	this	can	be	a	bit	
time	consuming,	it	will	give	you	more	familiarity	as	to	whether	there	
are	any	odd	channels	that	may	need	interpolating	later	on,	or	large	
artefacts	that	should	be	removed	from	any	further	analysis.		

b. To	plot:	Plot>Channel	data	(scroll)	
c. Remove	DC	offset:	Display>Remove	DC	offset	



	

	
d. To	move	through	the	plot	use	the	arrow	keys		
e. SAVE	(“ss_expt_name_scroll”)	

Scale	Event	
Number	

Settings:	Time	range	to	display,	Number	of	channels,	



	
4- Extract	triggers	(if	applicable)	

a. If	you	want	to	remove	triggers	(i.e.	remove	incorrect	trials	from	
analysis),	or	insert	different	labels	for	triggers	then	it	is	easier	to	do	this	
at	this	early	stage.	

b. To	extract	triggers	(EEG.event)	–	then	run	a	program	selecting	the	
triggers	you	want	–	the	important	information	to	keep	is	the	type	and	
latency	of	the	trigger.		

c. Add	event	triggers	into	file:	file>importeventfile>from	matlab	array:	
type	in	“EEG.event”	into	array	

d. SAVE	(“ss_expt_name_trig”)	
	

5- Import	channel	location	file	
a. Need	to	insert	channel	information.	This	is	stored	in	a	text	document	

with	electrode	label	and	x/y	co-ordinates	(location)	of	the	electrodes	
(e.g.	Cz	is	0,0)	

b. Edit>	Channel	locations	

	
i. Make	sure	BESA	spherical	file	is	selected>	Press	Ok	

c. Read	locations>	select:	GSN124_plus.loc	

	



i. Select:	autodetect>	Press	OK	

	
d. Press	Ok	on	Edit	chan	info	window	
e. In	data	set	file	–	Channel	Locations	should	now	have	changed	to	a	“yes”	

	
f. SAVE	(“ss_expt_name_chan”)	

	
6- Filters	(use	FIR)	

a. Tools>Filter	the	data	>	Basic	(FIR)	



	
b. Apply	high	pass	filter	first	(e.g.	0.01Hz)	

	
c. Once	the	data	has	been	high-pass	filtered	



d. Apply	low	pass	filter	next	(e.g.	80Hz)	

	
e. Note:	filtering	can	distort	data	or	clean	it	up,	Luck	has	a	great	chapter	

on	how	and	when	to	use	filters		
f. SAVE	(“ss_expt_name_filt”)	

	
7- Identify	Bad	Channels	

a. Tools>Automatic	channel	rejection	

] 		
b. The	Output	of	this	can	be	copied	into	an	Excel	file	and	saved.	
c. Highlight	any	channel	labelled	as	bad	and	take	note	of	the	electrode	

number	



	
d. OR:	Edit>Select	Data>Channel	Data	(I	AM	UP	TO	HERE!!)	

	
	

8- Interpolation	(as	a	preprocessing	step	-	do	this	once	you	have	run	through	1	
to	12	once)	Note:	you	can	also	interpolate	after	epoch	and	ica’ing	but	will	
have	to	re-reference	after	ICA.	

a. When	channels	are	bad/noisy/flat	and	are	contributing	to	epoch	
rejection	then	you	need	to	interpolate	the	electrode.	Interpolation		
takes	an	average	of	the	signal	from	surrounding	electrodes	so	that	the	



bad	signal	becomes	an	interpolation	of	the	signal	from	the	surrounding	
electrodes	

b. If	this	is	done	before	the	ICA	(i.e.	before	epoch	extraction)	the	data	
entered	into	the	ICA	is	clean	

c. Tools>Interpolate	electrodes	
d. Select	from	data	channels		

i. pick	channels	you	want	to	interpolate	

	
	

e. Interpolation	method:	spherical	method		
f. SAVE	(“ss_expt_name_interp”)	

	
9- Rereference		

a. Tools>Re-reference	

This	needs	to	be	spherical	

Select	data	channels	



b. For	an	average	reference:	
i. Click	“compute	average	reference”	
ii. 	In	box	for	“add	current	reference	channel	back	to	the	data”	type	

in	your	reference	channel	(e.g.	Cz)	

	
c. For	a	channel	reference	(e.g	mastoids:	TP9	and	TP10):		

i. Click	“re-reference	data	to	channel”	and	select	channels	you	
want	to	reference	to	

ii. In	box	for	“add	current	reference	channel	back	to	the	data”	type	
in	your	reference	channel	(e.g.	Cz)	

	
d. SAVE	(“ss_expt_name_reref”)	

	
	

10- 	Extract	data	epochs		
a. Once	pre-processed	data	(Steps	1-9),	use	the	final	pre-processed	data	

(“ss_seq_omit_interp”)	to	extract	data	epochs.	Need	to	decide	the	



triggers	(time	locking	events),	the	size	of	the	epoch	window	which	
includes	pre-stimulus	and	post-stimulus	(in	seconds	e.g.	-.5	to	1),	the	
baseline	(in	milliseconds	e.g.	-100	to	0)	

b. Tools>Extract	Epochs	

	
i. Time-locking	event:	select	triggers	
ii. Epoch	limits:	epoch	time	window	[start	time,	end	time]	
iii. Save	dataset	(“ss_expt_name_epoch_name”)	

	
iv. Popup:	baseline	removal	

	

Select	Epochs	–	by	pressing	….	

Epoch	time	window	(in	secs)	

Baseline	window	
(in	ms	e.g	-100	
to	0)	



IC1	–	maybe	
blink	

IC2	–	may	be	
eye	
movements	

1. Baseline	latency	range	[start	time	for	baseline,	end	time	
for	baseline]	(note	in	ms)>Ok	

2. SAVE:	File>	save	current	data	set	
(“ss_expt_name_epoch_name_base”)	

c. MAKE	SURE	YOU	SAVE	THE	EPOCHED	DATA	–	and	that	you	remove	the	
baseline	–	as	this	will	really	mess	up	your	trials	marked	for	rejections.		

d. If	you	are	looking	at	different	epochs	e.g.	pre-action	activity	vs	stimulus	
locked	ERP	then	need	to	create	different	epochs	for	each.	
	

11- 	Run	ICA	for	blink	correction		
a. In	order	to	remove	blink	artefacts	an	ICA	is	run	on	the	epoched	data	
b. Tools>Run	ICA	

i. This	will	take	a	while	–	it	can	be	from	an	hour	to	a	few	hours	
depending	on	the	size	of	your	epoched	data	

	
c. SAVE	(“ss_expt_name_epoch_name_ica”).	Make	sure	you	save	this	file	

–	as	you	don’t	want	to	redo	the	ica	because	you	forgot	to	save	it.	
d. To	look	at	the	ICAs:	Tools>Reject	Data	using	ICA>reject	components	by	

map	–	should	pop	up	a	window	that	asks	how	many	components	to	
plot	

																																				 	
e. Select	component	with	blinks	in	them	–	check	the	power	spectrum	(and	

eeglab	wiki	for	what	to	look	at)	



																									 	
	
	

f. Tools>Remove	components	(this	is	to	see	if	the	data	is	correcting	the	
blink)	

i. Enter	component	to	remove	from	data:	blink	ICA	no.	(e.g	1)	

	
ii. Leave	“component	to	overwrite”	blank	
iii. When	“confirmation”	dialog	box	opens	click	on	“plot	single	

trials”		

	
iv. The	red	line	in	the	plots	is	your	“corrected”	raw	trace	and	the	

black	line	is	your	previous	epochs	–	for	blink	correction	there	
should	be	a	big	difference	in	blinks	between	red	and	black	lines.	

Frontal	activity	only	

Events	spread	
across	epochs	

Power	log	shows	
no	real	peaks	

A	Blink	

Both	frontal	and	
occipital	activity	

Events	peak	
at	same	time	
across	epochs	

Not	a	Blink	



	

	
	

v. If	you	want	to	accept	for	rejection	then	click	ACCEPT	if	not	then	
click	CANCEL	

vi. SAVE	the	new	file	as	(“ss_expt_name_epoch_name_bc”)	

Black	line:	original	trace	
Red	Line:	corrected	trace	

If	blink:	the	corrected	
trace	affects	mainly	
frontal	channels	

If	blink:	the	corrected	
trace	should	flatten	
signal	of	the	blink	



g. Save	the	component	numbers	that	have	been	removed	in	excel	or	a	
notepad	document.	
	

12- 	Reject	Data	Epochs		
a. To	select	data	epochs	for	averaging	and	analysis	–	need	to	exclude	

epochs	based	on	a	specific	criteria	(such	as	extreme	values	or	low	signal	
drift	or	sudden	gradient	changes).	Only	epochs	that	meet	this	criteria	
will	be	included	in	analysis.	This	is	an	example	for	extreme	values.	

b. Tools>Reject	data	epochs>reject	extreme	values	
i. Upper/lower	limits	(+120/-120)	(or	100	depending	on	how	strict	

you	are).		
ii. Start	time/End	time:	specify	the	window	you	want	artefact	

rejection	to	take	place.	Generally	use	the	start	of	the	epoch	to	
the	end	of	the	epoch,	but	sometimes	you	may	want	a	large	
epoch	but	only	want	artefact	rejection	to	happen	over	a	smaller	
window.	

iii. Display	with	previously	marked	rejections	and	Reject	marked	
trials:	keep	at	default	“No”	

	
c. Popup	data	plot:	This	will	then	highlight	the	epochs	that	have	extreme	

values	in	them		

Upper	and	
Lower	limits	

Start	Epoch	
End	Epoch	



	
i. Similar	to	blink	correction	–	a	trace	in	an	electrode	that	is	red	

means	it	has	exceeded	your	criteria	
ii. You	can	visually	inspect	and	then	decide	whether	to	accept	them	

or	not.	
iii. If	you	think	the	epoch	is	ok	–	then	click	on	it	and	it	should	not	be	

highlighted	anymore	–	then	click	update	marks.	
iv. If	the	same	electrode	is	contributing	to	a	lot	of	rejected	epochs	

then	you	may	want	to	look	into	interpolating	that	channel	(you	
will	need	to	go	back	to	the	Interpolation	step)	

v. Can	determine	if	a	channel	is	contributing	to	rejection	threshold	
and	decide	to	interpolate	(see	9.	Interpolation).	

1. Epochs	that	are	going	to	be	rejected	are	in	workspace	as	
EEG.reject.rejthreshE	(channel	x	epoch	matrix).	

2. If	there	is	a	“1”	in	a	cell	it	means	it	is	tagged	for	rejection	
3. Sort	through	each	channel	(row)	to	determine	how	many	

epochs	are	marked	for	rejection	
4. Generally	if	there	is	at	least	20-25%	of	epochs	rejected	–	

then	the	channel	needs	interpolating		
5. EEG	lab	allows	interpolation	of	a	channel	at	this	point	too	

(refer	to	8	on	how	to	interpolate	a	channel).	

Electrode	exceeding	
threshold	



6. If	interpolating	at	this	point	then	must	apply	the	average	
reference	after	interpolation	and	not	at	the	preprocessing	
step	

d. Tools>Reject	data	epochs	>	reject	marked	epochs	(remember	once	you	
have	marked	epochs	to	reject	doesn’t	mean	that	they	have	been	
rejected)	Make	sure	you	do	this	step.	

e. SAVE	(“ss_expt_name_epoch_name_rej”)	
f. Take	note	of	the	no.	of	trials	rejected	–	for	erps	–	ideally	need	at	least	

80	trials	in	each	condition	(or	over	75	to	80%	of	all	trials	accepted)–	
anything	less	than	participant	should	be	rejected	from	further	analysis	
for	failing	to	reach	threshold	
	

13- 	Selecting	Data	Epochs	(Conditions)	
a. For	each	ica	corrected/artefact	rejected	epoch	

{ss_expt_name_epoch_name_rej	}	need	to	create	separate	conditions	
for	each	subject	

b. Edit>Select	Epochs/Events	
c. In	the	dialog	box	for	select	the	event	click	on	type	“…”	and	select	the	

condition	you	want	to	use	(you	will	create	one	of	these	condition	files	
for	each	condition)		

	

Only	select	
one	at	a	time	

Make	sure	this	
is	selected	



d. Need	to	select	(i.e.	click)	remove	epochs	not	referenced	by	any	
selected	event	–	OK	

e. Click	OK	for	warning	dialogue	box.	

	
f. Name	it	something	different–	and	save	all	of	these	files	to	a	folder	

within	your	epoched	data	folder.	Again	change	the	name	for	each	file.	
SAVE	(“ss_expt_name_epoch_name_condition_name“).	

g. Important:	Note	down	the	no.	of	epochs	that	are	now	included	in	that	
event	(as	this	may	be	important	for	subject	rejection	etc.)		

h. Redo	this	for	each	condition/event	you	want	to	look	at	-	make	sure	you	
go	back	to	the	set	file	containing	all	events	and	not	the	condition	files.	
	

14- 	Compare	Events	for	One	Subject	using	Plots	
a. Load	condition	datasets	(you	will	be	using	the	dataset	number	in	the	

eeglab	dialog	box	that	has	been	assigned	to	these	files)	
b. Plot>sum/compare	erps	

	
c. In	the	blank	white	spaces	enter	in	the	data	sets	you	want	to	plot	e.g.	1	

2	4	
d. If	want	to	average	together	then	click	“avg”	
e. If	don’t	want	the	average	across	the	entered	conditions	then	click	“all	

erps”	
f. If	you	want	to	compare	between	conditions	enter	one	set	of	data	sets	

in	“datasets	to	average”	then	put	the	comparison	data	sets	into	

Data	sets	to	plot	

To	create	SD	of	
average	

Single	trials/	
each	dataset	

average	

To	compare	
conditions	/datasets	

difference	

Alpha	criteria	

Negative	plotted	up	



“datasets	to	average	and	subtract”	-	make	sure	avg	is	clicked	for	both	
rows.	If	you	want	to	also	plot	the	difference	click	avg	in	the	plot	
difference	line	

g. If	you	want	to	highlight	which	regions	are	significant	then	enter	.05	into	
highlight	significant	regions.		

h. Other	aspects	of	this	dialog	box	are	about	whether	you	want	negative	
plotted	up	or	not	and	adjust	the	filtering	for	the	plots.	

i. Output:	Plots	of	your	conditions	across	the	scalp	

	
	

15- 	Creating	Grand	Averages	–	STUDY	function	
a. To	create	grand	averages	you	can	use	the	STUDY	function	in	eeglab	

i. You	can	check	the	wiki	to	find	out	how	to	use	this	
b. It	is	good	to	use	for	plotting	more	than	one	conditions	but	maybe	not	

so	good	to	run	statistics	in	
c. To	create	a	study:	File>Create	Study>Simple	ERP	Study	

i. Will	get	a	warning	about	needing	a	lot	of	memory	

	
ii. OK	

d. Window:	Create	simple	ERP	study	

Note:	need	to	have	
enough	memory	to	
open	many	data	files		



i. Number	of	conditions:	number	of	conditions	in	experiment	e.g.	
2	

ii. Number	of	subjects:	you	intend	to	analyse	in	the	study	function	

	
e. Create	a	new	Study	window:	

	

f. Will	get	a	pop	up	of	a	grand	average	plot	and	a	window	of	viewing	and	
editing	channels	–	press	OK	and	the	study	will	turn	up	in	the	eeglab	
workspace	

Number	of	conditions	
in	experiment		

Number	of	subjects		

Give	the	study	a	name	
e.g.	expt_label_study1		

Condition	Labels		

Condition	Datasets		

Use	…	to	browse	
for	files	associated	
with	conditions		



	
g. IMPORTANT:	SAVE	the	study.	File>save	current	study	as…	
h. When	reopen	study	file	the	options	are	under	the	Study	Tab	in	the	

toolbar	

	
i. Study>edit>edit	study	design	

i. Can	edit	the	study	–	add	in	more	subjects	etc	
	

j. Study>Plot	Channel	Measures	



	
i. Provides	a	window	of	view	and	edit	channels	
ii. Can	select	several	electrodes	to	plot	

1. Select	channels	
2. Plot	ERPS	

iii. Parameters	

	

Select	Channels	
Plot	ERP	

Select	time	limits	
for	plot	{-100	500]	

Amplitude	limits	of	plot	

In	Hz	just	for	plotting	
e.g	40Hz	–	useful	if	lots	
of	high	freq	noise	in	
data	

Select:	allows	
separate	conditions	
to	be	plotted	on	
same	graph	

Plots	data	as	ERPS	across	
each	electrode	

If	want	average	of	
electrodes	near	each	
other	



	
iv. Stats	

	

	

For	Topoplot:	Enter	time	
point	in	ms	and	select	“All	
Channels”	

Select	Channels	to	
run	Statistics	

Click	Statistics	

Options	are:	Parametric,	
Permutation,	Bootstrap	

Can	keep	exact	or	put	in	a	
threshold	e.g.	.05	

To	correct	for	multiple	
comparisons	



	
	

16- Creating	Grand	Averages	–	using	MATLAB	workspace	
a. Take	each	participants	data	for	a	given	condition	(e.g.	load	.set	file	for	

condition	1)	
b. Data	is	in	EEG.data	within	workspace	(this	is	a	big	matrix	of	numbers	

(3D	array):	channels	x	time	points	x	no.	of	epochs)	
c. You	need	to	create	a	2D	array	of	this	data	to	get	each	subject’s	data	

average	for	that	condition	(channels	x	time	points)	(i.e.	average	across	
the	number	of	trials	e.g.	ss_cond_avg	=	mean(data,	3))	

d. Use	each	ppts	average	for	that	condition	and	save	it	into	a	cell	matrix	-	
that	way	you	can	access	each	participants	averaged	data	easily	–	very	
handy	for	doing	later	statistics.	

e. To	create	a	grand	average:	
i. Need	to	concatenate	the	data	into	one	matrix	(use	cat	function	

in	matlab)	(i.e.	each	condition	has	each	subjects	matrix	
consisting	of	channels	x	time	points)	

ii. Then	average	together	on	last	dimension	(ndims+1)	–	this	
averages	across	subjects	

iii. This	should	give	you	a	64	(channels)	x	time	points	matrix	of	data	
points.	

iv. Do	this	for	each	of	your	conditions	and	save	into	one	structure	
v. Select	which	electrodes	you	want	to	plot.	Use	the	numbers	

assigned	in	the	channel	location	file	(e.g.	Cz	is	14)	
vi. Select	the	row	(based	on	the	electrode	you	want)	and	put	that	

data	row	into	a	grand-avg	matrix	you	will	use	to	plot	



vii. Do	this	for	each	condition,	but	attenuate	each	row	underneath	
the	previous	(otherwise	it	will	overwrite	the	previous	row)	

viii. You	should	end	up	with	a	matrix	where	each	row	corresponds	to	
all	ppts	average	data	for	each	condition	for	one	electrode.	

ix. Use	Plot	function	in	matlab	to	plot	the	grandavg	for	these	
conditions	at	one	electrode.	

x. Save	everything	as	a	.mat	file	that	can	be	loaded	into	matlab	
later.	

	
17- Statistics	

a. PCA?	
b. Visually	inspect	your	grand	averaged	ERPs	and	identify	your	

components	(Auditory	ERPs:	(p80),	N1,	P2,	P300.	Visual	ERPs:	P1,	N170,	
P3)	in	the	specific	electrodes	(Peaks:	Auditory	N1:	FCz,	Auditory	P2:	Cz,	
Auditory	P3:	CPz/Pz;	Visual	P1:	Iz,	Visual	N170:	Oz	(for	laterality	effects	
use	PO8	and	PO7))	

c. Select	your	time	windows	for	analysis.	For	each	component	need	a	
start	time	and	end	time	–	we	will	then	create	an	average	amplitude	
(µV),	for	each	condition,	across	each	subject	that	will	be	used	in	a	
statistical	parametric	test.	

i. Ideally	the	data	for	stats	tests	should	be	presented:	
1. Rows:	each	subjects	data	
2. Columns:	each	condition	(or	each	component_condition)	
3. Within	each	cell:	the	mean	average	(µV)	across	the	time	

window	for	that	condition	for	that	subject	
d. To	calculate	mean	averages	for	each	subject:	

i. Take	cell	arrays	created	in	15b(iv)	
ii. Take	each	subject’s	data	for	your	given	time	window	

(EEG.data(channel	no,	[start_timewindow:end_timewindow])	
1. This	should	create	a	matrix	of	all	electrodes	data	for	data	

points	within	this	time	window	
2. Averaging	across	the	time	windows	–	gives	you	the	mean	

amplitude	at	this	time	window	for	individual	electrodes	
iii. Take	the	mean	time	window	data	from	your	selected	electrode	

and	append	it	to	a	matrix	with	all	the	other	subjects	mean	
voltage	for	that	condition	(i.e.	each	subject	on	a	different	row)	
Then	concatenate	the	other	conditions	to	form	one	data	matrix	



of	subjects	x	conditions	(e.g.	16	subjects	with	4	conditions	
should	end	up	with	a	16x4	matrix	for	each	condition)	

iv. Steps	i	to	iv	may	differ	if	you	want	to	average	across	electrodes	–	
take	the	mean	of	the	electrode	sets	first	–	then	calculate	the	
average	within	the	time	window.		

v. The	final	matrix	can	then	be	saved	as	a	.mat	file	which	can	be	reloaded	
into	matlab	to	conduct	stats	tests	or	copied	into	SPSS	or	excel	to	create	
figures	or	run	more	tests.	
	

18- Time	Frequency	Analysis	
a. EEGLab	allows	you	to	make	time	frequency	calculations	on	your	data.	
b. Create	large	epochs	(containing	double/triple	the	time	of	the	lowest	

frequency	you	are	interested	in	–	so	if	you	want	to	look	at	4	Hz		=	a	
cycle	every	250ms	seconds	(1/4	=	.25),	then	you	need	each	epoch	to	be	
at	least	triple	that	on	each	side	(e.g	epoch	size	-500	to	500ms)	–	this	is	
due	to	the	tapering	function(?)	which	means	data	analysed	is	half	that	
around	the	epoch	size)	

c. Calculate	ersp	–with	outputs	
d. Ersp	is	a	matrix	of	freq	x	times	data	–	containing	complex	no.s	
e. These	complex	no.s	need	to	be	calulcated	(some	calculations	are	done)	
f. Average	
g. Oscillation	data	tends	to	need	to	be	log	transformed	and	to	do	a	power	

analysis	is	a	little	more	complicated	then	I	can	go	into	here.	
	

19- Convert	EEGLab	to	Fieldtrip	
If	you	want	to	look	into	oscillations	properly	I	would	suggest	doing	
preprocessing	and	epoching	in	EEGLab	and	then	transferring	everything	into	
fieldtrip.	Although	please	be	aware	that	fieldtrip	uses	MATLAB	command	
functions	and	does	not	have	a	GUI.	So	if	you	are	not	familiar	with	MATLAB	at	
all	–	it	may	take	a	bit	to	understand	what	is	going	on.	Also	note:	that	there	is	a	
specific	format	that	fieldtrip	uses	–	so	instead	of	having	to	start	the	
preprocessing/epoching	all	again,	there	are	a	few	quicker	ways	of	getting	the	
right	info	from	your	eeglab	file	and	using	it	in	your	fieldtrip	file.	In	particular	
fieldtrip	needs	information	about	trials,	epochs	and	filenames	–	unfortunately	
the	function	used	(eeglab2fieldtrip),	doesn’t	necessarily	extract	all	this	info,	so	
if	you	want	to	go	straight	into	frequency	processing	or	ERP	stats	analysis	then	
here	is	what	you	need	to	do:	



a. Download	the	fieldtrip	toolbox	(follow	the	install	instructions	on	the	
fieldtrip	wiki)	

b. Open	up	your	eeglab	file	(.set)	–	this	is	for	the	.set	files	that	have	
already	been	split	from	other	conditions.	

c. Insert	the	following	commands:	
i. data	=	eeglab2fieldtrip(EEG,	‘preprocessing’);	%	this	is	going	to	

convert	the	eeglab	data	file	to	a	fieldtrip	structure	file	–	but	also	
indicate	that	it	is	similar	to	a	“preprocessing”	file	from	fieldtrip	

ii. Get	info:	data.hdr	=	ft_readheader(filename);	data.events	=	
ft_read_event(filename),		

iii. To	get	data.trl	and	data.epochs	(important	for	fieldtrip	further	
analysis):		

1. data.epochs	=	(find(strcmp	(‘trial’,	{data.events.type})));	
%finds	the	no.	of	epochs	in	events.type.		

2. Then	cycle	through	the	epochs	in	data.epochs	to	get	
timing	information	for	each	trial		

a. Use	data.events(trial_no).sample	for	trial	onset	
b. Use	data.events(trial_no).duration	+	trial	onset	for	

trial	offset	
c. Use	data.events(trial_no).sample	for	trial	onset	
d. Use	data.events(trial_no).offset	for	offset	
e. create	a	matrix	where	on	each	row	you	have	the	

time	onset	of	trial	(trlbegin),	time	offset	of	trial	
(trlend),	and	the	difference	between	the	two	
(offset).	This	matrix	should	be	inserted	as	data.trl	

iv. Take	the	data	structure	that	you	have	created	(this	is	now	in	
fieldtrip	format)	and	save	it	as	a	.mat	file	(fieldtrip	saves	
everything	as	.mat	files)	and	you	should	be	ready	to	go.	

	


